对于外贸创业新人来说,快速搭建属于自己的独立网站是首先考虑的问题,准备用wordpress系统建站后需要解决的第一个问题是选用一个好主题,avada无疑是海外用户建站使用最多且历史悠久的建站主题。此主题使用时对于系统环境也有一定的要求。

我们推荐运行 Avada

  • 使用最新版本的WordPress。
  • PHP 版本7.3或更高版本。(注:Avada 7.2+兼容 PHP 8.0+)
  • MySQL 版本5.6或更高版本(MariaDB版本10.1+)。
  • HTTPS支持。
  • 检查运行 WordPress 的最低要求。

对于旧的环境,Avada 还可以使用 PHP 5.6.20+ 和 MySQL 5.0+,但这些版本已达到生命周期终点,因此可能会使您的站点面临安全漏洞。请注意,7.3 以下的所有 PHP 版本均已达到生命周期终点,不应再使用。

当 PHP 应用程序(如 WordPress)使用您帐户的用户名而不是服务器的默认共享用户名(www 或 www-data)运行时,托管会更安全。托管公司执行此操作的最常见方法是使用 suPHP。只需询问您的潜在主机是否运行 suPHP 或类似的东西。

推荐的 PHP 配置限制

您可能遇到的许多问题,例如:白屏死机、演示导入失败、Avada Builder 的页面内容为空以及其他类似问题都与 PHP 配置限制较低有关。解决方案是增加 PHP 限制。您可以自行执行此操作,或者联系您的网络托管服务商并要求他们将这些限制增加到最低限度,如下所示:

  • 最大执行时间 180
  • 内存限制 128M
  • post_max_size 32M
  • upload_max_filesize 32M

如何验证您当前的 PHP 限制

您可以在“系统状态”页面的“服务器环境”区域中验证您的 PHP 配置限制。从 WordPress 侧边栏,转到Avada > 维护 > 状态。此外,您可以随时联系您的房东,询问他们当前的设置是什么,并让他们根据需要进行调整。请注意,许多主机会无缘无故地尝试将 PHP 限制保持在较低水平。然而,您正在为此付出代价,因此您的钱应该物有所值。